Supported Operating Systems & Kernels

Follow

 

Supported Kernel & glibc Versions

Check your kernel version before running our agent or installing the auditd package.

Minimum linux kernel version v2.6.36 or greater
glibc version 2.7 or greater

Linux Kernel Conflicts

If your Threat Stack agent is greater than v1.4.0, it will detect the following incompatible kernel versions and abort the agent startup:

Linux Kernel Conflicts
3.13.0-50/51/52
3.16.0-36

Supported Operating Systems

The Threat Stack Agent is tested and supported on the following systems:

IMPORTANT!

At this time, Threat Stack only support 64-bit operating systems (x86_64 or amd64). We do not support ARM, x86_32 or other 32-bit process architectures.

Platform Version GNU libc Version Kernel Version Notes
Amazon 2012.09 201209 >= GNU libc 2.17 >= 3.2.21  
CentOS/RHEL 6 6 GNU libc 2.12 v2.6.36 FAnotify is not available on this platform so CentOS 6 does not support user information for FIM results. More details here.
CentOS/RHEL 7 7 2.17 3.10  
CoreOS 1353 1353.8.0 >= glibc 2.23, shipped with 1339.0.0 (alpha) >= 4.10.1 Requires manual installation.
Debian 7 7 >= Debian EGLIBC 2.13-38+deb7u01 >= 3.2  
Fedora 25 25 GNU C Library Version 2.24 4.10.x  
Ubuntu 14.04 14.04 >= Ubuntu EGLIBC 2.15-0ubuntu10.18 (~2.19) 3.13  
Ubuntu 16.04 16.04 Ubuntu GLIBC 2.23-0ubuntu9 3.13  

Supported Containers

Threat Stack supports the following container:

Important

Requires the latest Threat Stack Agent version and Linux kernel version >= 3.10.

Platform Version GNU libc Version Kernel Version Notes
Docker 1.8.0 - 17.03.2-ce   Ubuntu 3.10+ Requires the latest Threat Stack Agent version. Vulnerability monitoring not supported.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.