Upgrading the Threat Stack Agent.

Follow

The Server page has a call out for servers with an out of date agent. 

Clicking on this button will load a filter which includes all servers with agents older than the last two released agents.

 
Currently, upgrading the agent must be done on the box itself (it cannot be initiated from the UI).

NOTE: In order to get the latest agent version on Ubuntu 16, you have to completely uninstall the old agent and install the newest version.

Threat Stack has migrated the agent delivery over to our APT and YUM repositories.  Upgrading can be managed using your distributions normal package upgrade mechanisms.  

Additionally, you can leverage our Chef/Puppet/Salt/Ansible code available on Github to help you install/upgrade your agent.

https://github.com/threatstack/threatstack-chef
https://github.com/threatstack/threatstack-puppet
https://github.com/threatstack/threatstack-ansible
https://github.com/threatstack/threatstack-formula (for Salt) 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.